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SOES 6047 Global Climate Cycles

Practical 2
These practicals were designed to be carried out on workstations at the University of Southampton’s Waterfront Campus located at the National Oceanography Centre, Southampton as part of Master’s level courses, however any computer with a suitable operating system and software may be used to complete these practicals.

This practical requires a computer with access to a UNIX or LINUX operating system and the ‘splicer’ software installed, which can be downloaded from: http://www.ldeo.columbia.edu/BRG/ODP/ODP/CLIP/download.html 

Practical 2: Composite depth scales and using “Splicer”

After your first meeting with your new supervisor, you feel on top of things. You have managed to navigate geological databases and discovered many interestingly looking things that seem worth following up on. Ice-core data, ODP data and a lot of additional resources too; you feel like you discovered a whole new world of science! You wish you could go on one of those research cruises yourself, some time! As requested by your supervisor, you have now downloaded a whole set of data from ODP Leg 199, Site 1218, and feel pleased with yourself. Although the nagging doubt remains whether you did the right thing? Things are moving fast, and you have the next meeting with your “research colleague”, or THE BOSS.

She again seems very busy, and doesn’t quite appreciate your work. She only asks “Do you have those data ready? It was easy, wasn’t it. I hope you put them into the right format”. Ooops, you wonder .... “OK, I don’t have time this second, but one of my PhD students is down in the cluster room working with some data, and this terrible piece of software called Splicer.” You see here getting tense with anger, as if that programme has taken years of her life in frustration. “See if you can find space in the cluster room as well, and generate a composite depth scale and splice for the data, as I explained to you before”. Did she really explain it before, you wonder? You want to please the boss, though, so you try to show some initiative. On your way out the last thing you hear is “I forgot to ask, of course you have used UNIX before, no?”.

Procedure:

This practical aims to give you practice with fiddly “research grade” software, feature of which are (1) it runs on an unusual computer system (2) it crashes frequently and without warning (3) it has lots of quirks (4) it expects data in a specific format and (5) it is not particularly user friendly. Hence, welcome to “Splicer”. You will be at an advantage if you have used the command line facility of Unix/Linux/MacOS X before, but should be able to get along fine with the instructions below.

Start “Splicer”: by typing 

“./splicer.command” and hitting enter.

Now you should see the main window of Splicer on your screen. 

The window is likely to be slightly bigger than your screen, you can move around by moving the mouse pointer to the lower or right edge of the screen.
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After you start Splicer, you will see a screen looking similar to this:
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This is Splicer in its basic mode, with no data loaded. There are three main menu entries at the top, and an additional help one on the right.

You see two main window panes, a larger one on the left, and a second one (for the Splice), on the right, both with a meter depth scale on their left, and some scroll bars around the window. The black field at the bottom is a status indicator field, displaying information.

You can change the depth scale (how many meters you see at a given time, and the colour scheme for the window, in the View->Display Menu.
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This allows you to get a better data overview, or to zoom in. Importantly, it also allows you to set the horizontal (data unit) scale later (Variable minimum and maximum fields, now still dimmed because no data are loaded).

Now close this window, and load some data:

Choose the menu entry File->Open->Data file
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It is important to get familiar with this window.

The top row shows you where you are in the file system. If the preferences are corrupt, this might show a location that does not actually exist, in which case you can adjust it by hand.

In the current location in the directory structure, all files available are shown in the left box. The “..” to the top allows you to go up one directory. Your files must be properly formatted in ODP style (Leg Site Hole Core Coretype Section cm-interval mbsf datavalue1 datavalue2, all separated by tabs, and with UNIX line endings, see the Help menu for some additional information).

When you start Splicer for the first time from your username directory, you will have to navigate to the location where the ODP 1218 files are stored:

Click TWICE on the two full stops in the upper left hand side of the window, then click on SOES6047_P02 (or wherever you saved your data), and then on JanusData, until your window looks like below:
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You can now choose files from multiple holes, all for the same data type. Let’s start with the GRAPE bulk density data for Site 1218 (“gamma-ray attenuation porosity evaluator”). With the left mouse button, select the three grp_..... files on the left, they will indicate that they are selected. Clicking a file again, you can deselect it.

Now click on the right arrow button in the middle part of the window, to indicate your final selection
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You must always choose files of the same measurement type at a given time, i.e. you cannot mix grape density and magnetic susceptibility data.

In the top right hand quadrant, you can now adjust various important parameters, including the file format, the file header, whether to filter (prune) the data (Cull) and whether to apply any smoothing.

File Format: choose “ODP Other”, and look at the available options:
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You (almost) always want to use the last option as indicated, with data values in column 9. If you have a data file with more than one data column (e.g. colour reflectance data), you would increase the data column number to reflect the column you want, e.g. column 9 for lightness (L*), column 10 for a* (red-green) and so on.

Click OK

Back in the file selection window, now click File Header? Yes, and indicate how many header lines your data file has. For the files supplied here, choose three header lines (you can verify this by opening the file with a text editor like pico, you can always enter a higher number than what is actually there, but will lose one line of data if you do.).

Now choose the correct data type (GRAPE). This is only a label, and does not influence how the data are read or treated, you could call the mag. sus. data GRAPE, if you wanted, and you can use each label more than once.

Make sure the next button says “DON’T USE AFFINE”, unless you have some previous composite depth offsets saved, in which case clicking it allows you to specify where that file is saved.
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Now click on the “Cull...” button. 
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Here you can specify whether you want to use the raw data (click “No Cull parameters”), or whether you want to exclude data values smaller or greater than some threshold. This allows you to filter out spurious and noisy data that result from, e.g., half-empty cores, or core disturbance. For bulk density data, you do not expect to get values smaller than 0.7 and greater than 3, so click “Use Cull Parameters”, and enter those numbers into the field. You can experiment which cut-off values give you the best result. In addition, you can specify whether you want to ignore the top XXX cm from each core, as they are often disturbed. Splicer does not allow you to cull data at section tops (as supposed to core tops), and thus you might have to do some data cleaning or culling on the raw data in, e.g., Excel or a text editor. Now click OK.

From the file import window, now click on “No smooth”, where you can set up whether during import you would like your data to be smoothed (you can still do that later if you decide not to do it now).
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Smoothing can help you to more clearly see patterns in the data. Choose a Gaussian smoothing window of 9 points, displaying both smoothed and unsmoothed data, then click OK. (HINT: while Splicer runs, it remembers these settings for the same data type, so you don’t have to do it again when you import the same data label type again).

Now you are done, and you can click “OPEN” in the main file window, which will bring up a summary window, if you are happy click OK again.
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If everything is working correctly, you will see Splicer reading the data files, and present them on the left hand side of the screen for you. You can scroll up and down to see what the data look like (for Site 1218, the density variations are not apparent to ca. 50 mbsf. Notice the label in the bottom left “GRAPE”. If you load more data types, you can choose this button to switch screens between data types.
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Using one of the mouse buttons, you can click on a data curve, and get detailed information about that sample point (try it).

Now load the data files in a similar manner for magnetic susceptibility (files ms__, suitable cull range -10->500), P-wave velocity (pwl..., suitable cull range 1300-1600, colour reflectance (at least two curves, lightness in column 9, and a-b (red-green) variation in column 10, associated with data type “Other”).

If a data file refuses to load, it is usually one of two problems: (1) you did not specify the number of header lines (to skip) correctly, or (2) the file format is not correct (line ending, tab separated?)

On your screen you will now see the last data set you loaded, and can switch between them with the button on the bottom left. You can adjust the view scale for each variable separately (View->Display Menu).

Now begin your composte depth scale development, by choosing the menu “Process->Composite”, which will open up one additional window:
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Try out now what the three (or two) mouse buttons do when used over the main window data display area. You should manage to create a green and a red data indicator, and be able to shift cores up or down. The red coloured dot indicates the core that remains fixed in place, the green one can be moved while holding the appropriate mouse button. (Depending on the computer system you use, the “middle” (Unix) mouse button might be emulated as a Ctrl or Alt key combination with a two button mouse under Windows.

While you move cores up or down, you cannot go past the end of a particular core.

While you experiment with moving cores and data, observe the secondary window, which shows you cross-correlation graphs for all data sets, with the active one in blue.

It also shows you detailed information about the Core ID and depth.

Now you are ready to develop the composite depth scale:

Pick one top core that defines the mud-line, and remains in place (un-shifted). Adjust the next adjacent core choosing a correlative feature, until you are happy with the match.

Then, on the secondary window, make sure you select “To Tie”, which means your manual correlation (with an automatic option, too). You can then either shift this core and all below from the same hole, or just this core. It is usually easiest to shift all cores below, too.  When you are happy, press “Adjust Depth” on the secondary window, which puts your alignment into place.
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No work your way down in an iterative fashion. You might have a few false starts, where you have to start from scratch again. Annoying as it is, you might have to clear all data, and re-load them, if you need to go past the one Undo step possible. (File->Clear->All).

When you are happy with your composite depth scale, almost all cores should be shown in green, and you can save your composite depth (“affine”) table, by choosing the menu “File-->Save-->Affine Table”. This text file stores the applied vertical offset from mbsf to mcd for each core, and can be used when loading files from scratch. As Splicer crashes frequently, DO save and save often!!!
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Now you can create the Splice:

Choose Dismiss from the secondary composite depth window, and select the menu “Process->Splicer->Constrained”. The difference between constrained and unconstrained is that for constrained, you can not move composite depth adjusted cores relative to each other any more.

A new window (the “splicer correlation”) window will pop up, and you can now assemble your splice to fill gaps as needed.
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In the main window, scroll to the top, and click on the core that you would like to start your splice with. The identifier then appears in the second window, and you can click “Grab core” to make it part of the splice.

The core will then be shown in the right hand panel of the main window in light blue. Now grab the next core that is to be part of the splice, and it will be shown in green. You can use the middle mouse button to pick a point to switch from one core to the next:
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Carry on doing this, avoiding any sharp jumps in the data sets. When you are happy, click “Splice to Tie” in the Splice window, and carry on with the next core.

When you are done, close the “Dismiss” the splice window, and save everything (the Splice table, the spliced data sets (you have to do this for each data set separately), as well as the data files, which will now have the mcd composite depths in an additional column.

Plot the spliced data sets, using a tool of your choice . When you are done and have saved everything, close the splice window, and choose the menu “View->View Offsets”. This shows you the increase in relative depth of your composite record over meters below sea-floor. Do you observe an increase? What, if any, is it ? Can you think of processes that explain this (look at references from Lect. 2).

Have you observed any cyclical aspects in the data you worked with? If so, were they restricted to certain depth intervals? Which were the most useful data types for correlation?
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